2006年11月23日

MacPorts の gettext が問題

Darwinports がインストール直後からアップデートをしていないことを思い出して、更新しようとしたが、構築エラーが多々出てきた。問題なく構築出来ても実行すると共有ライブラリエラーで動かないものが出てきた(gnupgが動かないとは、、、)。

暫く、熟考後 gettext の中の共有ライブラリ libintl のバージョンの問題らしい。 とりあえず手動で修正しているが、なんと面倒なことよ。

というか、Darwinports/MacPorts は、依存関係が正しく設定されていない気がひしひしと感じるのだが、みんなはそう問題ないのかぁ。。。

0 件のコメント:

Cocoa Emacs 24.3 構築 (2013/03版)

暫く使っている Cocoa Emacs を更新していなかったので、24.3 に上げてみた。 当てるパッチは inline patch と ポップアップフリーズ対応パッチ くらい。 24.3 には既にフルスクリーン実装が入っているので、よく使われているフルスクリーンパッチは外し...